Project

General

Profile

Bug #470

Bug #471: Bistream 1.1.85 issues

Bistream 1.1.85 snapshots non générés

Added by Alexis Jeandet about 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority:
High
Start date:
16/07/2015
Due date:
% Done:

0%

Estimated time:
revision:
r0

Description

Les snapshots ne sont plus générés si la période de génération est changée.
Le comportement est observé avec les softs de vol 3.0.0, 3.0.3 et 3.0.8.
Avec le bistream 1.1.83c, ce comportement n'est pas observé, les snapshots sont générés de manière nominale.

D'autre part sur le bitstream 1.1.85, le coarstime ne semble pas s'incrémenter correctement, à chaque transition il passe rapidement par de mauvaises valeurs avant de se stabiliser sur la bonne.
Par exemple pour passer de 0x005 à 0x006 il va passer par 0x001 0x004 pendant quelques fractions de secondes avant de se stabiliser à 0x006.

snapshots_298secondes.png (13.8 KB) snapshots_298secondes.png Alexis Jeandet, 17/07/2015 08:10 PM
snapshots_16secondes.png (13.1 KB) snapshots_16secondes.png Alexis Jeandet, 17/07/2015 08:14 PM
snapshots_296secondes.png (13.8 KB) snapshots_296secondes.png Alexis Jeandet, 17/07/2015 08:16 PM
1101
1102
1103

History

#1 Updated by Alexis Jeandet about 6 years ago

  • Parent task set to #471

#2 Updated by Alexis Jeandet about 6 years ago

1101
1102
1103

Après vérification, il n'y a pas de bug sur l'incrémentation du temps.

Par contre il semblerait que certains registres supprimés n'étaient pas constants.
LFR_WP_DELTASNAPSHOT
LFR_WP_DELTA_F0
LFR_WP_DELTA_F0_2
LFR_WP_DELTA_F1
LFR_WP_DELTA_F2
LFR_WP_DATA_IN_BUFFER
LFR_WP_NBSNAPSHOT
LFR_WP_START_DATE

Le constat pour le moment, c'est que si on configure une période de 300 ou 600 secondes on obtient bien des snapsshots alors que pour moins de 298 on en obtient pas.

Quand on change la période des snapshots, ces registres sont modifiés:

  • Avec une période de 298 secondes(cela fonctionne):
  • Avec une période de 16 secondes(cela ne marche pas):
  • Avec une période de 296 secondes(cela ne marche pas):

#3 Updated by Alexis Jeandet about 6 years ago

Avec 297 secondes ça fonctionne, la limite semble donc être de 297 secondes.

#4 Updated by Alexis Jeandet about 6 years ago

  • Status changed from New to Resolved

Le bitstream 1.1.87 semble résoudre le problème, avec 16 et 32 secondes comme période de snapshots ça fonctionne.

Also available in: Atom PDF