Project

General

Profile

Actions

Bug #621

closed

Bug while downloading CDF files through Sciqlop's space data module

Added by Anonymous almost 6 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
legacy
Target version:
-
Start date:
12/02/2016
Due date:
% Done:

0%

Estimated time:
revision:
r0
blocked:
No
Sprint:

Description

It appears that 2 events can prevent data from being well-downloaded on CDAWeb servers :
- a 403 Forbidden HTML message is received or
- downloaded CDF has some missing bytes at the beginning of the file
This 2 events implies segfault when CDFcodec is attempting to reading the received file.

Tests performed in simple network environment case (Qt examples) do not reproduce these bugs.
Further investigation leads to 2 methods potentially involve in the bug :
- FileDownloader::gothead() and
- FileDownloaderTask::startPosition()

Actions #1

Updated by Anonymous almost 6 years ago

  • Status changed from New to Resolved
  • Assignee set to Anonymous

Problems were :

  • http range request was formed with bad range, because starting border was not assigned (thus set to a random number) =>download allowed but missing data
  • cdaweb reject range request with starting border equal to 0 => 403 http errors
Actions #2

Updated by Nicolas Aunai over 4 years ago

  • Status changed from Resolved to Closed
Actions #3

Updated by Nicolas Aunai almost 3 years ago

  • Category set to legacy
Actions

Also available in: Atom PDF